`
xuela_net
  • 浏览: 489278 次
文章分类
社区版块
存档分类
最新评论

Poj 1611 The Suspects

 
阅读更多



The Suspects
Time Limit:1000MS Memory Limit:20000K
Total Submissions:16690 Accepted:8015

Description

Severe acute respiratory syndrome (SARS), an atypical pneumonia of unknown aetiology, was recognized as a global threat in mid-March 2003. To minimize transmission to others, the best strategy is to separate the suspects from others.
In the Not-Spreading-Your-Sickness University (NSYSU), there are many student groups. Students in the same group intercommunicate with each other frequently, and a student may join several groups. To prevent the possible transmissions of SARS, the NSYSU collects the member lists of all student groups, and makes the following rule in their standard operation procedure (SOP).
Once a member in a group is a suspect, all members in the group are suspects.
However, they find that it is not easy to identify all the suspects when a student is recognized as a suspect. Your job is to write a program which finds all the suspects.

Input

The input file contains several cases. Each test case begins with two integers n and m in a line, where n is the number of students, and m is the number of groups. You may assume that 0 < n <= 30000 and 0 <= m <= 500. Every student is numbered by a unique integer between 0 and n−1, and initially student 0 is recognized as a suspect in all the cases. This line is followed by m member lists of the groups, one line per group. Each line begins with an integer k by itself representing the number of members in the group. Following the number of members, there are k integers representing the students in this group. All the integers in a line are separated by at least one space.
A case with n = 0 and m = 0 indicates the end of the input, and need not be processed.

Output

For each case, output the number of suspects in one line.

Sample Input

100 4
2 1 2
5 10 13 11 12 14
2 0 1
2 99 2
200 2
1 5
5 1 2 3 4 5
1 0
0 0

Sample Output

4
1
1

Source



算是比较裸的并查集,算是练练手,“查”的过程中用路径压缩效率高些....


#include <iostream>
#include <algorithm>
#include <cmath>
#include <cstdio>
#include <cstdlib>
#include <cstring>
#define MAX 30050
using namespace std;

int par[MAX];
int n,m;

void init()
{
    for(int i=0; i<n; i++)
    {
        par[i] = i;
    }
}

int find(int x)
{
    if(x != par[x])
    {
        par[x] = find(par[x]);
    }
    return par[x];
}

void connect(int a,int b)
{
    int x = find(a);
    int y = find(b);
    if(x < y)
        par[y] = x;
    else
        par[x] = y;
}

int main()
{
   int i,k,j,t,t1;
   while(cin >> n >> m)
   {
       if(n == 0 && m == 0)
            break;
       init();
       int cnt = 0;
       for(i=0; i<m; i++)
       {
           cin >> k;
           cin >> t;
           for(j=1; j<k; j++)
           {
               cin >> t1;
               connect(t,t1);
           }
       }
       
       for(i=0; i<n; i++)
       {
           if(find(i) == 0)
           {
               cnt++;
           }
       }
       cout << cnt << endl;
   }
   return 0;
}


分享到:
评论

相关推荐

Global site tag (gtag.js) - Google Analytics